हल: कैसे अपडेट करें

टाइपस्क्रिप्ट एक ऑब्जेक्ट-ओरिएंटेड भाषा है जो कई आधुनिक वेब-आधारित अनुप्रयोगों की रीढ़ बन गई है। यह जावास्क्रिप्ट का एक सुपरसेट है जो अन्य शक्तिशाली सुविधाओं के साथ-साथ स्थिर टाइप-चेकिंग की पेशकश करता है, जो आपके एप्लिकेशन को रनटाइम पर अधिक मजबूत और त्रुटि मुक्त बनाता है। डेवलपर्स द्वारा अक्सर सामना किए जाने वाले सामान्य परिदृश्यों में से एक टाइपस्क्रिप्ट प्रोजेक्ट में स्थानीय पैकेजों को अपडेट करने की आवश्यकता है।

आपके एप्लिकेशन के कुशल कामकाज के लिए अपने स्थानीय पैकेजों को अद्यतन रखना महत्वपूर्ण है। पुराने पैकेज होने से अनुकूलता संबंधी समस्याएँ हो सकती हैं और साथ ही आपके प्रोजेक्ट में बग भी आ सकते हैं। यह सावधानीपूर्वक रखरखाव यह सुनिश्चित करेगा कि आपका एप्लिकेशन नवीनतम सुविधाओं और सुरक्षा पैच के साथ समन्वयित रहे।

स्थानीय पैकेजों को अद्यतन करने की विधियाँ

ऐसे कुछ तरीके हैं जिनसे कोई स्थानीय पैकेजों को अद्यतन कर सकता है। दो सबसे आम तरीके हैं - एनपीएम रजिस्ट्री में नवीनतम संस्करण के लिए मैन्युअल रूप से जांच करना और पैकेज.जेसन फ़ाइल को अपडेट करना, या एनपीएम उपयोगिताओं का उपयोग करना जो इसे स्वचालित रूप से संभालते हैं।

प्रथमतः, आप मैन्युअल रूप से एनपीएम रजिस्ट्री पर जा सकते हैं, अपने प्रोजेक्ट द्वारा उपयोग किए जाने वाले प्रत्येक पैकेज के नवीनतम संस्करणों को देख सकते हैं, और नवीनतम के साथ मिलान करने के लिए अपने पैकेज.जेसन फ़ाइल में संस्करण संख्याओं को अपडेट कर सकते हैं।

// package.json

{
  "name": "Your-App-Name",
  "version": "1.0.0",
  "dependencies": {
    "react": "^16.13.0",
    "typescript": "~3.7"
  }
}

वैकल्पिक रूप से, आप संस्करणों की जांच और अद्यतन करने की प्रक्रिया को स्वचालित करने के लिए एनपीएम-चेक-अपडेट जैसी एनपीएम उपयोगिताओं का उपयोग कर सकते हैं।

एनपीएम-चेक-अपडेट के साथ गहराई से गोता लगाएँ

एनपीएम-चेक-अपडेट या एनसीयू एक उपयोगिता है जो आपकी निर्भरता के नवीनतम संस्करणों को शामिल करने के लिए आपकी पैकेज.जेसन फ़ाइल को स्वचालित रूप से समायोजित करती है।

एनपीएम-चेक-अपडेट का उपयोग करने के लिए, आपको पहले कमांड का उपयोग करके इसे विश्व स्तर पर इंस्टॉल करना होगा - एनपीएम इंस्टॉल -जी एनपीएम-चेक-अपडेट.

// Install ncu
$ npm i -g npm-check-updates

फिर, अपने प्रोजेक्ट फ़ोल्डर में, कमांड चलाएँ NCU, यह उन निर्भरताओं की एक सूची प्रदर्शित करेगा जिन्हें अद्यतन करने की आवश्यकता है।

// Check for updates
$ ncu

अंत में, अपनी package.json फ़ाइल को अपडेट करने के लिए, बस कमांड चलाएँ एनसीयू-यू. यह आपकी निर्भरता को आपके package.json फ़ाइल में परिभाषित संस्करण नीतियों के अनुसार नवीनतम संस्करणों में अपग्रेड कर देगा।

// Upgrade packages
$ ncu -u

पैकेजों को अद्यतन करना और अद्यतन कार्रवाई का सत्यापन करना

संकुल को अद्यतन करने के लिए, कमांड चलाएँ एनएमपी स्थापित करें. यह package.json फ़ाइल में परिभाषित संस्करणों के अनुसार पैकेज स्थापित करेगा।

// Install updated packages
$ npm install

अंत में, कमांड चलाकर सत्यापित करें कि पैकेज अपडेट कर दिए गए हैं एनपीएम पुराना. यह उन निर्भरताओं की एक तालिका प्रदर्शित करेगा जो पुरानी हो चुकी हैं।

// Verify updates
$ npm outdated

इन चरणों का पालन करने के बाद, आपके टाइपस्क्रिप्ट प्रोजेक्ट में आपके स्थानीय पैकेज को अब अपडेट किया जाना चाहिए। यह सुनिश्चित करेगा कि आपका एप्लिकेशन आपकी निर्भरता के नवीनतम संस्करणों पर चलता है, नवीनतम सुविधाओं, अनुकूलन और सुरक्षा पैच से लाभान्वित होता है।

संबंधित पोस्ट:

एक टिप्पणी छोड़ दो